Browse Source

Upgrading the code generator and develop instructions

Juan Blanco 1 year ago
parent
commit
90795364f5
2 changed files with 11 additions and 16 deletions
  1. 9 14
      README-DEVELOP.md
  2. 2 2
      package.json

+ 9 - 14
README-DEVELOP.md

@@ -23,20 +23,15 @@ There are a number of nodejs packages are needed, like [typescript](https://www.
 which is described in a below [section](#how-to-run-code-in-this-github-repository).
 
 
-## Dependency hell
-
-This code is known to work with:
-
-* (Microsoft) code 1.30.2
-* nodejs 8.9.4; truffle 5 libraries request at least this
-* (npm) vscode 1.1.30
-
-Starting with Microsoft code 1.31 (or 1.32) you will get a crash when you try to run this code.
-Also, starting with those versions, you need nodejs 10 or greater.
-
-To be able to have several nodejs versions around, there is [nvm](https://github.com/creationix/nvm).
-
-
+## Dependency hell / Current Issues
+There is a dependency on isomorphic-fetch
+if having issues compiling, replace the index.d.ts file with this
+
+```typescript
+declare namespace _fetch { }
+declare const _fetch: any;
+export = _fetch;
+```
 
 
 # How to run code in this github repository

+ 2 - 2
package.json

@@ -10,7 +10,7 @@
     "nethereum",
     "solhint"
   ],
-  "version": "0.0.54",
+  "version": "0.0.55",
   "publisher": "JuanBlanco",
   "engines": {
     "vscode": "^1.28.0"
@@ -56,7 +56,7 @@
     "find-cache-dir": "^2.1.0",
     "fs-extra": "^4.0.3",
     "mkdirp": "^0.5.1",
-    "nethereum-codegen": "^1.0.10",
+    "nethereum-codegen": "^1.0.11",
     "require-from-string": "^2.0.2",
     "solc": "^0.5.8",
     "solhint": "^2.0.0",